rabbit-dev

現役スマフォプログラマーが適当にプログラム関係の記事を放り込むブログ

「Xcode cannot run using the selected device.」の対処方法

XCodeで実機デバッグしようとすると以下のエラーがでた。

 \

f:id:rabbittan:20141004182824p:plain

 

Xcode cannot run using the selected device.

No provisioned iOS devices are available with a compatible iOS version. Connect an iOS device with a recent enough version of iOS to run your application or choose an iOS simulator as the destination.

 

先日まで正常に動いていたのに、なんでかな?と思ったらiPhoneのアップデートをしていて、iOS8.0.2になっていたためだった。

 XCodeを6.0.1にアップデートしたら正常に実機デバッグができた。


 

f:id:rabbittan:20141004182825p:plain